Hatchlings Games

Web Gaming 2.0 Revolution

Installing mongrel on Debian / Ubuntu

While installing mongrel on Debian / Ubuntu, you might encounter the following error:

Building native extensions. This could take a while…
extconf.rb:1:in `require’: no such file to load — mkmf (LoadError) from extconf.rb:1

This can be fixed by getting the ruby1.8-dev package using apt-get [replace ruby1.[x] with the version you are using].

sudo apt-get install ruby1.8-dev

Continue installing mongrel, mongrel_cluster, etc.

Advertisements

April 24, 2007 Posted by | Programming, Web 2.0 | 2 Comments